Tutorials
41 Kommentare

HMIP LAN Gateway für die CCU

Sicherlich haben viele von euch einen Homematic IP Gateway “rumliegen”. Rumliegen aus dem Grund, da dieses Gateway oft in günstigen Sets dabei ist und daher bei vielen noch irgendwie in der Schublade liegt. Ich selbst habe auch zwei.

Eines von diesen beiden Gateways hat nun aber eine andere Aufgabe. Mit dem neusten Update der CCU3 Firmware ist es nun möglich, den Access Point als Gateway zu nutzen.

LAN Gateway?

Ein LAN Gateway ist etwas tolles, um Dein Funkbereich der Homematic IP Komponenten zu erweitern. Somit ist es mit diesem Gateway möglich, dass das Signal zunächst einmal von der CCU über das lokale Netzwerk (Kabel – kein WLAN) zu verschicken und danach über das Gateway via Funk an den Aktor geschickt wird. In dem Beispiel aus diesem Artikel können über das Gateway Homematic IP Aktoren und Sensoren angebunden werden – nicht aber die Klassischen Homematic Produkte. Hierfür muss das “normale” Gateway genutzt werden – aber natürlich gibt es dazu auch eine Lösung – HIER ZU LESEN.

Umwandeln vom HMIP Access Point

Wichtig hierbei ist als erstes, dass die CCU mit der neusten Firmware ausgestattet ist. Nur dann ist es möglich, den Access Point in ein Gateway umzuwandeln. Also zunächst einmal dieses Updaten – aber WICHTIG – vorher noch ein Backup machen. Man weiss ja nie ….

Ist das Backup erstellt, so kann die offizielle Firmware einfach eingespielt werden. Nutzt Du RaspberryMatic, dann musst Du zum heutigen Tag noch eine experimentelle Firmware einspielen (link unten). Da der Entwickler aber schnell sein Projekt weiter vorbringt ist es sicherlich auch bald mit der “offiziellen” Firmware möglich.

Die CCU ist nun also auf dem neusten Stand. Nun einfach das Gateway mit dem Netzwerk und Strom verbinden – warten bis die LED blau leuchtet – und dann in das WebUI der CCU wechseln. Hier die Systemsteuerung öffnen und dort auf den Punkt “Access Points mit inkompatibler FW” aufrufen. Was für ein Name für ein Button ….

Hier kann nun der Access Point mit der speziellen Firmware beschrieben werden. Ist dies erledigt, so leuchtet der Access Point nun Türkis. Gibt es hier Probleme, so hat bei mir es geholfen den Access Point nochmal zu resetten. Wie das geht beschreibe ich HIER.

Klappt nicht?

Falls es doch noch Probleme gibt, dann habe ich im Homematic Forum noch einen weiteren Tipp gefunden, den ich hier noch gern mit Kopiere/Poste. Vielleicht hilft er ja:

Habe den HAP jetzt nach einem doppelten Werksreset an einer aktiven Internetverbindung gemäß Benutzerhandbuch
(Seite 19) resetten können:

- Vom Strom trennen, LAN Kabel drin lassen
- Bei gedrücktem Taster Strom zuführen und Taster halten, bis HAP beginnt orange zu blinken
- Taster los lassen und erneut drücken und halten bis HAP grün leuchtet, Taster los lassen
- Sobald HAP blau leuchtet Prozess wiederholen (laut EQ-3 innerhalb von 5 min)
- Nach dem zweiten Reset vorsichtshalber noch einmal vom Strom getrennt bevor ich die FW mit der CCU installiert habe
- FW installieren unter Systemsteuerung > Access Points mit inkompatibler FW
- Gerät auswählen und Passwort eingeben
- Update erfolgreich installier

Anlernen ging danach auch:
- HAP vom Strom trennen
- CCU3 in Anlernmodus für HMIP bringen
- HAP am Strom anschließen, nichts drücken
- HAP leuchtet nun türkis als LAN Gateway
- Gerät wird anschließend im Posteingang gelistet und danach unter Geräte angezeigt

Anlernen

Das Anlernen ist nun recht einfach. Einfach den Anlernmodus öffnen und schon ist das Gateway im Posteingang zu finden. Das war’s eigentlich auch schon. Als Einstellungsmöglichkeit gibt es nur den Punkt, dass wir die Helligkeit der LED anpassen können.

Video

Links

Experimentelle Firmware der RaspberryMatic: https://github.com/jens-maus/RaspberryMatic/releases/tag/snapshots

HMIP Access Point: https://amzn.to/3ksOBXk

Vielleicht auch interessant?

Es wurden keine Ergebnisse gefunden, die deinen Suchkriterien entsprechen.

Beitrag teilen:

41 Kommentare. Hinterlasse eine Antwort

  • Vielen Dank für den Beitrag. Genau das Thema steht jetzt bei mir bald an. Habe das ELV-Angebot von MAX! auf HMIP zu wechseln angenommen und bekomme jetzt zwei HMIP-AP, die ich auf diesem Wege dann hoffentlich auch mit der piVCCU als LAN-Gatway nutzen kann.

    Antworten
  • Genau das habe ich auch gemacht wie Volker. Deshalb seht gut dieses Video.
    Danke Stefan

    Antworten
  • Hallo Stefan,

    super Video’s machst du auf deinem Kanal, die sehr hilfreich sind. In einem deiner neueren Video’s erklärst du die Einrichtung einen HmIP-HAP als LAN-Gateway. Soweit hat auch alles funktioniert, ich kann den HmIP-HAP als Gerät auf meinem RaspberryMatic in den Geräteeinstellungen sehen.

    Wie kann ich das LAN Gateway nun einrichten und die entsprechenden HmIP-Geräte dem neuen LAN-Gateway zuweisen?

    Für die Homematic Geräte hattest du ein Video erstellt.

    Mfg Dominik

    Antworten
    • Hans-Peter Huegli
      22. Mai 2021 13:48

      Hallo Stefan,
      Danke für das Video! Habe wie mein Vorredner die gleiche Frage welche ich nirgens schlüssig gefunden habe. Eventuell kannst Du da weiterhelfen.
      Die Frage: “Wie kann ich das LAN Gateway nun einrichten und die entsprechenden HmIP-Geräte dem neuen LAN-Gateway zuweisen?”
      Vielen Dank für ein kurzes Feedback
      Mfg Hans-Peter

      Antworten
      • Hallo! Das geht leider nicht. Bei dem HM Gateway fand ich es auch besser, dass man die Geräte einfach fest zuweisen kann. Dies läuft bei den HMIP Geräten automatisch. Das heisst, dass diese sich selbst den AP suchen, der den besten Empfang hat

  • Andreas Münnich
    23. September 2020 17:28

    Bei Problemen mit dem Erkennen des HmIP-HUP:
    siehe https://homematic-forum.de/forum/viewtopic.php?f=65&t=61053 und https://homematic-forum.de/forum/viewtopic.php?f=71&t=60714&start=20

    Mein Fazit: einfachen 100MBit Switch vor CCU und HAP und es klappt klaglos!

    Letztlich finde ich aber:
    Das soll ja wohl ein absoluter Witz von eQ3 sein! zum Einen sollen Die das halt eindeutig als Grundvoraussetzung schreiben oder besser programmieren!
    Wer betreibt denn heute noch ein Netz wo er allen (insbesondere die historischen Arten) Broadcast ungehindert rumschwirren läßt!?

    Antworten
  • Hallo Stefan,
    meinst du man kann auch das neue HmIP-WLAN-HAP (WLAN-Unterstützung) so umbauen. Dan würde man sich den LAN Anschluss sparen und könnte die Geräte noch gezielter aufstellen ?
    MFG
    Volker

    Antworten
  • VolkerGBenner
    24. September 2020 8:56

    Das flashen der Firmware klappt bei mir. ( piVCCU3 auf Raspi3B) Der HMIP-HAP wird zum Lan-Gateway und die SystemLED leuchtet dauerhaft türkis. Er läßt sich aber dann nicht anlernen. Kann das an piVCCU liegen?

    Antworten
    • andreas münnich
      24. September 2020 11:54

      100MBit Switch vor CCU und HAP und es klappt klaglos!

      Antworten
      • VolkerGBenner
        24. September 2020 14:59

        Die sind gemeinsam an einem 1Gbit-Switch angeschlossen. Was soll die Drosselung auf 100MBit bewirken, wenn darauf die Betonung liegt und nicht auf dem Switch selber?

  • Andreas Münnich
    24. September 2020 16:35

    EINFACHER 100 mbit switch …. sorry da war ich vorher zu ungenau …. ein switch, der nicht in den Ethernetverkehr eingreift … die „Herren“ von eQ3 scheinen auf alte und netzwerkflutende Broadcastingtechnik zurückgegriffen zu haben, die in heutigen Durchschnittsswitchen geblockt werden!

    Antworten
  • Hallo
    mein Problem ist (nutze die CCU3 mit aktueller Firmware 3.53.30 ) das ich zwar das update starten konnte und die CCU3 auch dien Button hat aber ich kann den nicht anklicken und somit auch nichts anlernen oder sonst was machen mit dem AP

    Hat jemand eine lösung??

    mfg
    Jürgen

    Antworten
    • VolkerGBenner
      2. Oktober 2020 22:44

      Ich weiß jetzt woran es bei mir lag. Ich habe mit einer piVCCU3 geflasht, das funktioniert. Ich hatte aber nur das alte HM-MOD-RPI-PCB Modul auf dem Pi, und für das anlernen der HAPs als LAN-GW bedarf es der KryptoFunktionen des neuen RPI-RF-MOD. Also neues Modul bestellt, getauscht, läuft.

      Antworten
      • habe aber keinen PI und frage mich warum ich den button habe aber nicht drücken kann
        aber zudem kommt auch das mein HMIP-HAP nur rot blinkt

  • VolkerGBenner
    3. Oktober 2020 7:39

    “nur rot blinkt” würde ich drauf tippen, dass er nicht vollständig in den Werkszustand gesetzt ist. Immer zweimal hintereinander durchführen. Wichtig auch, den HAP im Router vom Internet zu trennen, sonst besorgt der sich sofort wieder die OrignialFW, sobald er gestartet wird.

    Antworten
  • VolkerGBenner
    3. Oktober 2020 11:08

    Der Button hat auch keine Funktion mehr, sobald er nicht mehr als HMIP-HAP arbeitet. Wenn der HAP zum LAN-GW geflasht wird, übernimmt die CCU die vollständige Kontrolle.

    Antworten
  • Ich meine den Button an der ccu3
    Nach dem Update ist der zwar da um den hap zu konfigurieren aber den kann ich nicht anklicken

    Antworten
  • Dirk Tenkamp
    16. Oktober 2020 17:11

    “Ich meine den Button an der ccu3
    Nach dem Update ist der zwar da um den hap zu konfigurieren aber den kann ich nicht anklicken”

    Das Problem habe ich leider auch!
    Sind sie damit weitergekommen?

    Antworten
  • Dirk Tenkamp
    16. Oktober 2020 17:45

    Problem gelöst.
    Ich habe die Firmware einfach nochmal installiert!

    Antworten
  • VolkerGBenner
    21. Oktober 2020 12:12

    Ich habe jetzt auch meinen zweiten HMIP-HAP zum Lan-Gateway gemacht. Interessant oder vielmerh merkwürdig war dabei, dass er unter dem CCU3-Menüpunkt “Access Points mit inkompatibler FW updaten” unter keinen Umständen angezeigt wurde und deswegen auch kein offensichtlicher Flash-Vorgang stattfand. Irgendwann hab ich aus purem Frust einfach mal “Geräte anlernen” gestartet und der Button des HAP wechselte spontan von Blau auf Türkis und lies sich als Gateway anlernen. Hab ihm dann sofort den Internetzugang gesperrt.
    Ob er wirklich als Gateway arbeitet hoffe ich anhand der RSSI erkenne zu können, da die Gateways ja nicht konfigurierbar sind.

    Antworten
    • Hallo Volker, genauso war es bei mir auch, nun bin ich mir unsicher, ob das Gerät auch wirklich als Repeater läuft… es wurde ja keine neue Firmware geflasht. Angezeigt wird er als Router, türkis leuchtet er auch. Was ist “RSSI” und läuft deiner nun als Gateway? Vielen Dank,

      Antworten
  • Andreas Münnich
    21. Oktober 2020 14:48

    ich hab nun 1 HmIP-Gateway seit ein paar Wochen aktiv … komischerweise hat sich die Empfangsstärke von in 3 Metern Luft-Entfernung befindlicher HmIP-Geräte nicht verbessert. z.B. ein HmIP-SRH mit Abstand zur CCU3 von 5 Meter durch 2 Betondecken vor Einstatz des HmIP-Hub -93dBm und mit HmiP-Hub in 3 Meter Entfernung Luft nicht verändert …..

    Antworten
  • Hallo,
    ich bin absoluter Neuling in der RaspberryMatic Welt und brauche mal eine kleine Hilfe.
    Ich habe die neueste RaspberryMatic Version in einer VM auf einer Synology laufen. Dort angeschlossen habe ich einen Funkstick für HomeMatic IP was auch ohne Probleme klappt und für mich die einfachste Möglichkeit war. Leider ist dieser nach meinen Recherchen nicht für ein LAN-Gateway geeignet, sprich ich brauche also eine neue “Funkvariante” die ich per USB an die Synology anschließen kann.

    Könnte jemand eine Einkaufliste posten, was ich neben der Funkplatine “RPI-RF-MOD” noch benötige?

    Vielen Dank 🙂

    Grüße Sven

    Antworten
  • Super Anleitung, manchmal steht man ja tatsächlich was auf dem Schlauch.
    Gibt es außer Reichweitenerhöhung noch weitere Vorteile des HAP, wenn man eine CCU nutzt?
    Die Möglichkeit dann die App zu nutzen ergibt sich wahrscheinlich nicht, oder?

    Antworten
  • Hi, ich habe einen Pi4, mit HM-MOD-RPI-PCB + externe Antenne und RaspberryMatic 3.55.10.20210213 laufen an dem bereits einige Geräte angelernt sind und auch soweit funktionieren.
    Jetzt wollen wir das erweitern und waren begeistert von der Möglichkeit die HAPs als LanGateway zu nutzen. Leider klappt das mit dem flashen nicht, weil das RF-MOD benötigt wird lauf popup. Muss ich jetzt wirklich ein RPI-RF-MOD kaufen um die beiden HAPs als Gateway nutzen zu können? Die APs haben 2.2.18 als Firmware.
    Jemand ne idee? Würde echt ungern noch ein Modul kaufen, zumal dann der Pi4 mit dem großen Board nicht in ein Gehäuse passt.

    Antworten
    • Hallo! So wie ich selbst gelesen habe ich das Modul wirklich notwendig um den HMIP-HAP einbinden zu können. Auch später für den Betrieb braucht er dieses Modul

      Antworten
      • Danke auf jeden Fall für die Antwort und das Video. Sehr lehrreich.
        Mit einem RPI-RF-MOD mein komplettes Setup neugemacht, weil das Backup einspielen nicht die Geräte mitgeliefert hat, ich vermute wegen dem Modul Wechsel. 🙁
        Das Modul funktioniert, und die APs konnte ich ohne Probleme anlernen. Nur leider blinken die APs nach wenigen Minuten wild türkis statt stabil zu leuchten. und Geräte mit weniger als 3m Entfernung zum AP verlieren die Verbindung (Betonkeller). Das ist wenig hilfreich, da kann ich gleich versuch längere Antennen dranzulöten.

      • Hallo! So etwas habe ich bisher nicht gehört. In dem Fall würde ich einmal direkt bei eQ-3 anrufen und fragen

  • Christian Schulze
    21. Februar 2021 8:06

    Hallo zusammen!
    Danke zuerst für die tolle Anleitung.
    Wieso zum Geier ist denn der Dutycycle der HAP so gering (< 5%) im Gegensatz zu dem der CCU3?!
    Habe das Gefühl das die Hap zwar das sind aber quasi kein Datenverkehr darüber läuft … und ja die Einrichtung hat funktioniert und wir auch unter Geräte angezeigt.

    Vielen Dank im Voraus.

    Antworten
    • Hallo! Kommt auch immer drauf an, welche Geräte mit dem HAP Kommunizieren. Die Telegramme von einem Thermostat z.B. sind viel größer als von einem Temperatursensor. Und je mehr Daten übertragen werden – desto höher natürlich auch der Duty Cycle

      Antworten
  • Hallo,

    nochmal ein Feedback zu meiner Situation. Es hat mich nicht in Ruhe gelassen, dass das mit den HAPs nicht klappt mit der Kommunikation und die LEDs Türkis blinken. Ich denke ich auf eine Lösung gestossen in den Kommentaren bei ( https://technikkram.net/blog/2020/09/27/homematic-ip-access-point-als-lan-router-auf-ccu3-installieren-und-anlernen/) und zwar scheint es sich in der Tat um ein Problem mit IGMP Snooping (war auf meinem Managed Switch eingeschaltet) zu handeln. Einfach beschrieben handelt es sich hier um eine Technik die man normalerweise haben will weil sie “Schreihälse” im Netzwerk daran hindert das Netzwerk “tot zu brüllen” (u.a. wenn man T-Entertain hat wird viel Verkehr verursacht der an alle Teilnehmer im Netz geht, was man normalerweise nicht will). Diese Technik scheint aber bei der Kommunikation zwischen CCU (RaspberryMatic) und den HAPs (als LAN Router konfiguriert) zum tragen zu kommen (leider, das macht man so heute eigentlich nicht mehr). Kurz nachdem ich auf meinem Switch das IGMP Snooping abgeschaltet hatte, haben die HAPs aufgehört wie wild zu blinken, und die Kommunikation an den “entfernten Enden” (HAPs im Keller und Dachgeschoß) scheint zu funktionieren. Zumindest habe ich seitdem keine “Unreach Meldungen” von Geräten mehr gesehen.
    So, jetzt habe ich genug geschrieben, aber vielleicht hilft das jemandem von Euch das Problem der Kommunikation zwischen CCU und HAP zu lösen. Es soll, wenn man das IGMP Snooping nicht abschalten kann, auch helfen statt einem managed switch einen HUB zu nutzen, das hab ich jetzt nicht mehr ausprobiert weil ich dafür meine Inhouse Verkabelung “zerlegen” müsste, und das will man in Zeiten des Corona HomeOffice und Homeschooling nicht wirklich machen

    Antworten
  • Hallo,

    kann ich dann auch sagen welche IP Geräte über die IP Gateway Antenne funken sollen und welche nicht?
    so wie es früher über die Lan Gateway Antennen ging?

    Antworten
  • Hartmut Heinze
    1. November 2021 17:03

    Hallo Stefan,
    danke für den Beitrag.
    Kann ich auch einen “Homematic IP WLAN Access Point” so nutzen?

    Gruß Hartmut

    Antworten
    • Hallo,
      wie meinst Du das? Also WLAN ist dies in dem Sinne nicht – mit dem klassischen WLAN, dass auch für Laptops usw. genutzt wird hat es nichts zu tun.

      Antworten
      • Hartmut Heinze
        4. November 2021 20:20

        Hallo Stefan,
        in dem Beitrag benutzt du einen “HMIP Access Point”.
        Kann ich auch einen “HMIP WLAN Access Point” benutzen um eine HMIP-LAN Gateway zu erzeugen?
        Gruß Hartmut

      • Hi! Ach ja – das Gerät hatte ich gar nicht mehr im Kopf. Nach meinem aktuellen Kenntnisstand geht das leider noch nicht. Soll aber wohl noch kommen.

  • ich nutze debmatic in einer VM auf einen Intel NUC mit Proxmox. Ich habe das RPI-RF-MOD Modul. Da mein Intel NUC mit dem Modul im Keller ist, habe ich mir nun einen HAP um das Signat zu erweitern besorgt und bereits angelernt.Hat alles geklappt.
    Wenn ich jedoch nun meine Rollos im DG ühber die WebUI fahren möchte, so erhalte ich immer die Meldung Gerätekommunikation gestört, nach einiger Zeit (1-2 Minuten) fährt das Rollo dann aber.Firmware ist die 3.59.6.78

    Antworten

Schreibe einen Kommentar

Deine E-Mail-Adresse wird nicht veröffentlicht. Erforderliche Felder sind mit * markiert.

Bitte füllen Sie dieses Feld aus.
Bitte füllen Sie dieses Feld aus.
Bitte gib eine gültige E-Mail-Adresse ein.

Weitere ähnliche Beiträge auf verdrahtet.info:

Menü